|
{...}: let
|
|
httpIntAddr = "10.13.1.1";
|
|
httpIntPort = 14210;
|
|
dom = "pw.min.rip";
|
|
in {
|
|
services.nginx.virtualHosts.${dom} = {
|
|
forceSSL = true;
|
|
enableACME = true;
|
|
|
|
locations."/" = {
|
|
proxyPass = "http://${toString httpIntAddr}:${toString httpIntPort}";
|
|
};
|
|
};
|
|
}
|